man.bsd.lv manual page server

Manual Page Search Parameters

USBD_STATUS(9) Kernel Developer's Manual USBD_STATUS(9)

usbd_statusUSB device drivers interface return status values

#include <dev/usb/usbdi.h>

This documents the full list of return values used by the generic USB code. Interface-specific definitions will be given with interface.

Return values are split into two main groups: expected values and error values.

There are only two expected values:

The operation completed successfully.
The operation was successfully submitted, usually part of an asynchronous operation.

These are the error values:

The requested operation could not be completed due to pending requests, usually from a pipe close operation.
The initial status of a USB transfer. See usbdi(9) for more details about USB transfers.
Invalid arguments were supplied for the requested operation.
No memory could be allocated.
The USB transfer has been cancelled, and not completed.
The requested USB pipe could not be found. See usbdi(9) for more details about USB pipes.
The requested operation could not be performed due to the device having active connections, such as USB audio device currently playing.
USB bus has reached its maximum limit of devices.
Call to usbd_set_address() failed during new USB device discovery.
New device has requested more power than is available.
New USB Hub too deep from the root.
Non-specific error happened during IO.
USB device is not configured; it has no configuration descriptor.
Operation timed out.
USB transfer succeeded but not all requested data was returned.
USB controller has stalled (controller specific.)
Process was interrupted by external means (such as a signal) while waiting for a transfer to complete.

usb(4), usbdi(9)

This usbd_status interface first appeared in NetBSD 1.4.

May 12, 2012 NetBSD-9.2