man.bsd.lv manual page server

Manual Page Search Parameters

MSTOHZ(9) Kernel Developer's Manual MSTOHZ(9)

mstohz, hztomsconvert between milliseconds and system clock ticks

#include <sys/param.h>

int
mstohz(int ms);

int
hztoms(int hz);

The () macro can be used to convert time in milliseconds to system clock ticks, as used by the callout(9) facility, in an integer-overflow safe way. Conversely, () converts system clock ticks to milliseconds.

These macros are defined in the ⟨⟩ header. Individual ports can have a processor-specific, more efficient version implemented in their ⟨⟩ header as a define.

The return value is either the number of clock ticks or milliseconds for the specified value.

param(3), callout(9), tvtohz(9)

Neither mstohz() nor hztoms() make use of expensive 64-bit integer arithmetic. The result from mstohz() will be rounded down to one second if the parameter is larger than 131072 milliseconds.

October 20, 2011 NetBSD-9.2