man.bsd.lv manual page server

Manual Page Search Parameters

BZERO(9) Kernel Developer's Manual BZERO(9)

bzerowrite zeroes to a byte string

#include <sys/systm.h>

void
bzero(void *b, size_t len);

The () interface is obsolete. Do not add new code using it. It will soon be purged. Use memset(9) instead. (The bzero() function is now a macro for memset(9).)

The () function writes len zero bytes to the string b. If len is zero, bzero() does nothing.

memset(9)

July 7, 2001 NetBSD-9.2