man.bsd.lv manual page server

Manual Page Search Parameters

PMAP_PINIT(9) Kernel Developer's Manual PMAP_PINIT(9)

pmap_pinit, pmap_pinit0initialize pmap structures

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/pmap.h>

void
pmap_pinit(pmap_t pmap);

void
pmap_pinit0(pmap_t pm);

The () function initializes the preallocated and zeroed structure pmap, such as one in a vmspace structure.

The () function initializes the physical map pm, associated with process 0, the first process created in the system.

The pmap_pinit2() function has been deprecated, and should be implemented as a stub until further notice.

pmap(9), pmap_growkernel(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.

July 21, 2003 FreeBSD-12.0