man.bsd.lv manual page server

Manual Page Search Parameters

MICROUPTIME(9) Kernel Developer's Manual MICROUPTIME(9)

binuptime, getbinuptime, microuptime, getmicrouptime, nanouptime, getnanouptime, sbinuptime, getsbinuptimeget the time elapsed since boot

#include <sys/time.h>

void
binuptime(struct bintime *bt);

void
getbinuptime(struct bintime *bt);

void
microuptime(struct timeval *tv);

void
getmicrouptime(struct timeval *tv);

void
nanouptime(struct timespec *ts);

void
getnanouptime(struct timespec *tsp);

sbintime_t
sbinuptime(void);

sbintime_t
getsbinuptime(void);

The () and getbinuptime() functions store the time elapsed since boot as a struct bintime at the address specified by bt. The microuptime() and getmicrouptime() functions perform the same utility, but record the elapsed time as a struct timeval instead. Similarly the nanouptime() and getnanouptime() functions store the elapsed time as a struct timespec. The sbinuptime() and getsbinuptime() functions return the time elapsed since boot as a sbintime_t.

The (), (), (), and () functions always query the timecounter to return the current time as precisely as possible. Whereas getbinuptime(), getmicrouptime(), getnanouptime(), and getsbinuptime() functions are abstractions which return a less precise, but faster to obtain, time.

The intent of the (), (), (), and () functions is to enforce the user's preference for timer accuracy versus execution time.

bintime(9), get_cyclecount(9), getbintime(9), getmicrotime(9), getnanotime(9), microtime(9), nanotime(9), tvtohz(9)

This manual page was written by Kelly Yancey <kbyanc@posi.net>.

February 21, 2015 FreeBSD-12.0