man.bsd.lv manual page server

Manual Page Search Parameters

MICROTIME(9) Kernel Developer's Manual MICROTIME(9)

bintime, getbintime, microtime, getmicrotime, nanotime, getnanotimeget the current time

#include <sys/time.h>

void
bintime(struct bintime *bt);

void
getbintime(struct bintime *bt);

void
microtime(struct timeval *tv);

void
getmicrotime(struct timeval *tv);

void
nanotime(struct timespec *ts);

void
getnanotime(struct timespec *tsp);

The () and getbintime() functions store the system time as a struct bintime at the addresses specified by bt. The microtime() and getmicrotime() functions perform the same utility, but record the time as a struct timeval instead. Similarly the nanotime() and getnanotime() functions store the time as a struct timespec.

The (), (), and () functions always query the timecounter to return the current time as precisely as possible. Whereas getbintime(), getmicrotime(), and getnanotime() functions are abstractions which return a less precise, but faster to obtain, time.

The intent of the (), (), and () functions is to enforce the user's preference for timer accuracy versus execution time.

binuptime(9), getbinuptime(9), getmicrouptime(9), getnanouptime(9), microuptime(9), nanouptime(9), tvtohz(9)

The bintime functions first appeared in FreeBSD 5.0. The microtime and nanotime functions first appeared in FreeBSD 3.0 but have existed in other incarnations since 4.4BSD.

This manual page was written by Kelly Yancey <kbyanc@posi.net>.

September 16, 2004 FreeBSD-12.0