man.bsd.lv manual page server

Manual Page Search Parameters

DEVICE_DELETE_CHILD(9) Kernel Developer's Manual DEVICE_DELETE_CHILD(9)

device_delete_childdelete a child from a device

#include <sys/param.h>
#include <sys/bus.h>

int
device_delete_child(device_t dev, device_t child);

The specified device is removed from dev and deleted. If the device is currently attached, it is first detached (see DEVICE_ATTACH(9) and DEVICE_DETACH(9)).

Zero is returned on success, otherwise an error is returned.

device_add_child(9)

This manual page was written by Doug Rabson.

June 16, 1998 FreeBSD-12.0