man.bsd.lv manual page server

Manual Page Search Parameters

DEVICE_ATTACH(9) Kernel Developer's Manual DEVICE_ATTACH(9)

DEVICE_ATTACHattach a device

#include <sys/param.h>
#include <sys/bus.h>

int
DEVICE_ATTACH(device_t dev);

Attach a device to the system after the () method has been called and has indicated that the device exists. The () method should initialize the hardware and allocate other system resources (such as devfs(5) entries).

Devices which implement buses should use this method to probe for the existence of devices attached to the bus and add them as children. If this is combined with the use of bus_generic_attach(9) the child devices will be automatically probed and attached.

Zero is returned on success, otherwise an appropriate error is returned.

devfs(5), device(9), DEVICE_DETACH(9), DEVICE_IDENTIFY(9), DEVICE_PROBE(9), DEVICE_SHUTDOWN(9)

This manual page was written by Doug Rabson <dfr@FreeBSD.org>.

January 15, 2017 FreeBSD-12.0