man.bsd.lv manual page server

Manual Page Search Parameters

BUS_GENERIC_ATTACH(9) Kernel Developer's Manual BUS_GENERIC_ATTACH(9)

bus_generic_attachgeneric implementation of DEVICE_ATTACH for buses

#include <sys/param.h>
#include <sys/bus.h>

int
bus_generic_attach(device_t dev);

This function provides an implementation of the DEVICE_ATTACH(9) method which can be used by most bus code. It simply calls device_probe_and_attach(9) for each child device attached to the bus.

Zero is returned on success, otherwise an appropriate error is returned.

device(9), driver(9)

This manual page was written by Doug Rabson.

January 15, 2017 FreeBSD-12.0