man.bsd.lv manual page server

Manual Page Search Parameters

BUS_SET_RESOURCE(9) Kernel Developer's Manual BUS_SET_RESOURCE(9)

bus_set_resourceassociate a definite resource with a given resource ID

#include <sys/param.h>
#include <sys/bus.h>


#include <machine/bus.h>
#include <sys/rman.h>
#include <machine/resource.h>

int
bus_set_resource(device_t dev, int type, int rid, rman_res_t start, rman_res_t count);

The () function sets the start address of the resource type, rid pair to be count long. Typically, client drivers do not use this interface. Bus drivers, however, often use it to set up the resources a client driver uses.

The arguments are as follows:

dev
The device to set the resource on.
type
The type of resource you want to allocate. It is one of:

for IRQs
for ISA DMA lines
for I/O ports
for I/O memory
rid
A bus-specific handle that identifies the resource being allocated.
start
The start address of this resource.
count
The length of the resource. For example, the size of the memory in bytes.

Zero is returned on success, otherwise an error is returned.

bus_alloc_resource(9), bus_get_resource(9), device(9), driver(9)

This manual page was written by Warner Losh <imp@FreeBSD.org>.

March 29, 2003 FreeBSD-12.0