man.bsd.lv manual page server

Manual Page Search Parameters

VOP_VPTOFH(9) Kernel Developer's Manual VOP_VPTOFH(9)

VOP_VPTOFHturn a vnode into an NFS filehandle

#include <sys/param.h>
#include <sys/vnode.h>

int
VOP_VPTOFH(struct vnode *vp, struct fid *fhp);

This is used by the NFS server to create an opaque filehandle which uniquely identifies the file and which can be used by an NFS client to access the file in the future.

Its arguments are:

vp
The vnode to make a filehandle for.
fhp
Return parameter for the filehandle.

VFS(9), VFS_FHTOVP(9), vnode(9)

This manual page was written by Doug Rabson.

February 16, 2007 FreeBSD-12.0