man.bsd.lv manual page server

Manual Page Search Parameters

VFS_FHTOVP(9) Kernel Developer's Manual VFS_FHTOVP(9)

VFS_FHTOVPturn an NFS filehandle into a vnode

#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>

int
VFS_FHTOVP(struct mount *mp, struct fid *fhp, struct vnode **vpp);

The () macro is used by the NFS server to turn an NFS filehandle into a vnode.

The arguments it expects are:

mp
The file system.
fhp
The filehandle to convert.
vpp
Return parameter for the new locked vnode.

The contents of the filehandle are defined by the file system and are not examined by any other part of the system. It should contain enough information to uniquely identify a file within the file system as well as noticing when a file has been removed and the file system resources have been reused for a new file. For instance, UFS file system stores the inode number and inode generation counter in its filehandle.

A call to () should generally be preceded by a call to VFS_CHECKEXP(9) to check if the file is accessible to the client.

The locked vnode for the file will be returned in *vpp.

VFS(9), VFS_CHECKEXP(9), vnode(9), VOP_VPTOFH(9)

This manual page was written by Doug Rabson.

January 4, 2010 FreeBSD-12.0