man.bsd.lv manual page server

Manual Page Search Parameters

STORE(9) Kernel Developer's Manual STORE(9)

store, casu32, casu64, subyte, suword32, suword64store data to user-space

#include <sys/types.h>
#include <sys/time.h>
#include <sys/systm.h>
#include <sys/resourcevar.h>

uint32_t
casu32(volatile uint32_t *p, uint32_t oldval, uint32_t newval);

uint64_t
casu64(volatile uint64_t *p, uint64_t oldval, uint64_t newval);

int
subyte(uint8_t *base, uint8_t byte);

int
suword32(uint32_t *base, int word);

int
suword64(uint64_t *base, uint64_t word);

The store functions are designed to copy small amounts of data to user-space.

The store routines provide the following functionality:

()
Compares the 32 bit oldval with the 32 bits at base, and if equal, base is set to newval. The old value at base is then returned.
()
Compares the 64 bit oldval with the 64 bits at base, and if equal, base is set to newval. The old value at base is then returned.
()
Stores a byte of data to the user-space address base.
()
Stores 32 bits of data to the user-space address base.
()
Stores 64 bits of data to the user-space address base.

The store functions return 0 on success or -1 on failure.

copy(9), fetch(9)

January 26, 2017 DragonFly-5.6.1