man.bsd.lv manual page server

Manual Page Search Parameters

FETCH(9) Kernel Developer's Manual FETCH(9)

fetch, fubyte, fuword32, fuwordadd32, fuword64, fuwordadd64fetch data from user-space

#include <sys/types.h>
#include <sys/time.h>
#include <sys/systm.h>
#include <sys/resourcevar.h>

int
fubyte(const uint8_t *base);

int32_t
fuword32(const uint32_t *base);

uint32_t
fuwordadd32(volatile uint32_t *p, uint32_t val);

int64_t
fuword64(const uint64_t *base);

uint64_t
fuwordadd64(volatile uint64_t *p, uint64_t val);

The fetch functions are designed to copy small amounts of data from user-space.

The fetch routines provide the following functionality:

()
Fetches a byte of data from the user-space address base.
()
Fetches 32 bits of data from the user-space address base.
()
Fetches 32 bits of data from the user-space address p, adds val, and stores the result back to the user-space address p.
()
Fetches 64 bits of data from the user-space address base.
()
Fetches 64 bits of data from the user-space address p, adds val, and stores the result back to the user-space address p.

The fetch functions return the data fetched or -1 on failure.

copy(9), store(9)

November 17, 2018 DragonFly-5.6.1