man.bsd.lv manual page server

Manual Page Search Parameters
MXGE(4) Device Drivers Manual MXGE(4)

mxgeMyricom Myri10GE 10 Gigabit Ethernet adapter driver

To compile this driver into the kernel, place the following lines in your kernel configuration file:

device mxge
device mxgefw

Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):

if_mxge_load="YES"

The mxge driver provides support for PCI Express 10 Gigabit Ethernet adapters based on the Myricom LANai Z8E chip. The driver supports Transmit/Receive checksum offload, TCP Segmentation Offload (TSO), multiple reception queues, multiple tranmission queues and multiple vector MSI-X. Using multiple vector MSI-X requires that Myri10GE NIC be capable of MSI-X. Older Myri10GE NICs can be field upgraded to add MSI-X using the "Myri-10G Network Adapter Toolkit" for FreeBSD or Linux which is available from https://www.myricom.com/support/downloads/tools/myri-10g-toolkit.html.

For questions related to hardware requirements, refer to the documentation supplied with your Myri10GE adapter. All hardware requirements listed apply to use with DragonFly. For further hardware information, see http://www.myricom.com.

The mxge driver supports the following media options:

Enable flow control PAUSE reception. Due to hardware limitation, this will also enable PAUSE transmission.
Enable flow control PAUSE transmission. Due to hardware limitation, this will also enable PAUSE reception.
Force flow control PAUSE operation as configured by rxpause and txpause media options. This media option can't be turned off.

For more information on configuring this device, see ifconfig(8). The mxge driver supports polling(4).

The mxge driver supports 10 Gigabit Ethernet adapters based on the Myricom LANai Z8E chips:

X is the device unit number.

hw.mxge.msix.enable hw.mxgeX.msix.enable
By default, the driver will use MSI-X if it is supported. This behaviour can be turned off by setting this tunable to 0.
hw.mxge.msi.enable hw.mxgeX.msi.enable
If MSI-X is disabled and MSI is supported, the driver will use MSI. This behavior can be turned off by setting this tunable to 0.
hw.mxgeX.msi.cpu
If MSI is used, it specifies the MSI's target CPU.
hw.mxge.num_slices hw.mxgeX.num_slices
If MSI-X is used, this value determines the maximum number of slices the driver will attempt to use. Setting this value to 0 allows driver to enable as many slices as allowed by the number of CPUs. Each slice is comprised of one reception queue and one transmission queue. The transmission queue of each slice, except the first slice, could be disabled. The default value is 0.
hw.mxge.multi_tx hw.mxgeX.multi_tx
If more than 1 slice is enabled, this tunable controls whether the tranmission queue of each slice should be enabled. Setting this tunable to 0 will only enable the transmission queue on the first slice. The default value is 1.
hw.mxge.use_rss
This tunable controls whether standard RSS input hash function or chip private input hash function should be used. Using standard RSS input hash function degenerates reception performance significantly. The default value is 0.
hw.mxge.intr_coal_delay
This value delays the generation of all interrupts in units of 1 microsecond. The default value is 150.
hw.mxge.flow_ctrl
The default flow control settings. Supported values are: force-full (forcefully enable PAUSE reception and transmission). force-none (forcefully disable flow control PAUSE operation). Default is force-none.

A number of per-interface variables are implemented in the dev.mxge.X branch of the sysctl(3) MIB.

firmware_version
The version string of firmware that is currently loaded by the driver. It is read-only.
use_rss
See tunable hw.mxge.use_rss. Flipping its value will cause chip reinitialization.
intr_coal_delay
See tunable hw.mxge.intr_coal_delay.

For general information and support, go to the Myricom support website at: https://www.myricom.com/support.html.

altq(4), arp(4), ifmedia(4), netintro(4), ng_ether(4), ifconfig(8), firmware(9)

The mxge device driver first appeared in FreeBSD 6.3. It was first ported to DragonFly 2.3.

The mxge driver was written by Andrew Gallatin <gallatin@FreeBSD.org>.

May 25, 2017 DragonFly-5.6.1