man.bsd.lv manual page server

Manual Page Search Parameters

IFMEDIA(4) Device Drivers Manual IFMEDIA(4)

ifmedianetwork interface media settings

#include <sys/socket.h>
#include <net/if.h>
#include <net/if_media.h>

The ifmedia interface provides a consistent method for querying and setting network interface media and media options. The media is typically set using the ifconfig(8) command.

There are currently four link types supported by ifmedia:

Asynchronous Transfer Mode
Common Address Redundancy Protocol
Ethernet
IEEE802.11 Wireless LAN

The following sections describe the possible media settings for each link type. Not all of these are supported by every device; refer to your device's manual page for more information.

The lists below provide the possible names of each media type or option. The first name in the list is the canonical name of the media type or option. Additional names are acceptable aliases for the media type or option.

The following media types are shared by all link types:

Autoselect the best media. [autoselect, auto]
Jumper or switch on device selects media. [manual]
Deselect all media. [none]

The following media options are shared by all link types:

Place the device into full-duplex mode. This option only has meaning if the device is normally not full-duplex. [full-duplex]
Place the device into half-duplex mode. This option only has meaning if the device is normally not half-duplex. [half-duplex]
Driver-defined flag. [flag0]
Driver-defined flag. [flag1]
Driver-defined flag. [flag2]
Place the device into hardware loopback mode. [hw-loopback]

The following media types are defined for Asynchronous Transfer Mode:

Unknown media type. [Unknown, UNKNOWN]
25Mb/s over unshielded twisted pair. [UTP/25.6MBit, UTP-25]
AMD TAXI, 100Mb/s over multi-mode fiber optic cables. [Taxi/100MBit, TAXI-100]
AMD TAXI, 140Mb/s over multi-node fiber optic cables. [Taxi/140MBit, TAXI-140]
155Mb/s over multi-mode fiber optic cables. [Multi-mode/155MBit, MM-155]
155Mb/s over single-mode fiber optic cables. [Single-mode/155MBit, SM-155]
155Mb/s over unshielded twisted pair. [UTP/155Mbit, UTP-155]
622Mb/s over multi-mode fiber optic cables. [Multi-mode/622MBit, MM-622]
622Mb/s over single-mode fiber optic cables. [Single-mode/622MBit, SM-622]

The following media types are defined for Ethernet:

HomePNA 1.0, 1Mb/s. [homePNA]
10BASE-T, 10Mb/s over unshielded twisted pair, RJ45 connector. [10baseT/UTP, UTP, 10UTP]
10BASE2, 10Mb/s over coaxial cable, BNC connector, also called Thinnet. [10base2/BNC, BNC, 10BNC]
10BASE5, 10Mb/s over 15-wire cables, DB15 connector, also called AUI. [10base5/AUI, AUI, 10AUI]
10BASE-STP, 10Mb/s over shielded twisted pair, DB9 connector. [10baseSTP, 10STP]
10BASE-FL, 10Mb/s over fiber optic cables. [10baseFL, 10FL]
100BASE-TX, 100Mb/s over unshielded twisted pair, RJ45 connector. [100baseTX, 100TX]
100BASE-FX, 100Mb/s over fiber optic cables. [100baseFX, 100FX]
100BASE-T4, 100Mb/s over 4-wire (category 3) unshielded twisted pair, RJ45 connector. [100baseT4, 100T4]
100BASE-T2. [100baseT2, 100T2]
100VG-AnyLAN. [100baseVG, 100VG]
1000BASE-SX, 1Gb/s over multi-mode fiber optic cables. (short waves) [1000baseSX, 1000SX]
1000BASE-LX, 1Gb/s over single-mode fiber optic cables. (long waves) [1000baseLX, 1000LX]
1000BASE-CX, 1Gb/s over shielded twisted pair. (twinax) [1000baseCX, 1000CX]
1000BASE-T, 1Gb/s over category 5 unshielded twisted pair, 802.3ab, RJ45 connector. [1000baseT, 1000T]
10GBASE-LR, 10Gb/s over single-mode fiber optic cables. [10Gbase-LR]
10GBASE-SR, 10Gb/s over multi-mode fiber optic cables. [10Gbase-SR]
10GBASE-CX4, 10Gb/s over XAUI 4-lane PCS and copper cables. [10Gbase-CX4]
2500BASE-SX, 2.5Gb/s over multi-mode fiber optic cables. [2500BaseSX, 2500SX]
10GBASE-T, 10Gb/s over unshielded twisted pair, RJ45 connector. [10Gbase-T]
40GBASE-CR4, 40Gb/s over twin-ax copper cable. [40GBASE-CR4]
40GBASE-SR4, 40Gb/s over multi-mode fiber optic cables. [40GBASE-SR4]
40GBASE-LR4, 40Gb/s over single-mode fiber optic cables. [40GBASE-LR4]

The following media options defined for Ethernet:

Configure a 1000BASE-T PHY as the clock master for a 1000BASE-T link. This option has no effect (shows current status only) if the media is IFM_AUTO.
Configure the device to send PAUSE (flow control) frames. This option has no effect (shows current status only) if the media is IFM_AUTO.
Configure the device to receive PAUSE (flow control) frames. This option has no effect (shows current status only) if the media is IFM_AUTO.

The following media types are defined for IEEE802.11 Wireless LAN:

Frequency Hopping 1Mbps. [FH/1Mbps, FH1, FrequencyHopping/1Mbps]
Frequency Hopping 2Mbps. [FH/2Mbps, FH2, FrequencyHopping/2Mbps]
Direct Sequence 354Kbps. [DS/354Kbps, DS354K, DirectSequence/354Kbps]
Direct Sequence 512Kbps. [DS/512Kbps, DS512K, DirectSequence/512Kbps]
Direct Sequence 1Mbps. [DS/1Mbps, DS1, DirectSequence/1Mbps, CCK1]
Direct Sequence 2Mbps. [DS/2Mbps, DS2, DirectSequence/2Mbps, CCK2]
Direct Sequence 5Mbps. [DS/5.5Mbps, DS5, DirectSequence/5.5Mbps, CCK5.5]
Direct Sequence 11Mbps. [DS/11Mbps, DS11, DirectSequence/11Mbps, CCK11]
Direct Sequence 22Mbps. [DS/22Mbps, DS22, DirectSequence/22Mbps]
Orthogonal Frequency Division Multiplexing 3Mbps. [OFDM/3Mbps OFDM3]
Orthogonal Frequency Division Multiplexing 4.5Mbps. [OFDM/4.5Mbps OFDM4.5]
Orthogonal Frequency Division Multiplexing 6Mbps. [OFDM/6Mbps, OFDM6]
Orthogonal Frequency Division Multiplexing 9Mbps. [OFDM/9Mbps, OFDM9]
Orthogonal Frequency Division Multiplexing 12Mbps. [OFDM/12Mbps, OFDM12]
Orthogonal Frequency Division Multiplexing 18Mbps. [OFDM/18Mbps, OFDM18]
Orthogonal Frequency Division Multiplexing 24Mbps. [OFDM/24Mbps, OFDM24]
Orthogonal Frequency Division Multiplexing 27Mbps. [OFDM/27Mbps, OFDM27]
Orthogonal Frequency Division Multiplexing 36Mbps. [OFDM/36Mbps, OFDM36]
Orthogonal Frequency Division Multiplexing 48Mbps. [OFDM/48Mbps, OFDM48]
Orthogonal Frequency Division Multiplexing 54Mbps. [OFDM/54Mbps, OFDM54]
Orthogonal Frequency Division Multiplexing 72Mbps. [OFDM/72Mbps, OFDM72]

The following media options are defined for IEEE802.11 Wireless LAN:

Ad-hoc mode. [adhoc]

In some drivers, it may be used with the IFM_FLAG0 [flag0] media option to specify non-standard ad-hoc demo mode.

Access Point mode. [hostap]
IBSS mode. [ibss]
MBSS mode. [mesh]
Monitor mode. [monitor]
Turbo mode. [turbo]
WDS mode. [wds]

The following operating modes are defined for IEEE802.11 Wireless LAN:

Autoselect the best mode. [autoselect, auto]
Orthogonal Frequency Division Multiplexing, 5GHz. [11a]
High Throughput, 5GHz. [11na]
Direct Sequence mode. [11b]
Complementary Code Keying, 2GHz. [11g]
High Throughput, 2GHz. [11ng]
Gaussian Frequency Shift Keying, 2GHz. [fh]

netintro(4), ifconfig(8)

September 30, 2014 DragonFly-5.6.1