man.bsd.lv manual page server

Manual Page Search Parameters

VFS_VPTOFH(9) Kernel Developer's Manual VFS_VPTOFH(9)

VFS_VPTOFHturn a vnode into an NFS filehandle

#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>

int
VFS_VPTOFH(struct vnode *vp, struct fid *fhp);

This is used by the NFS server to create an opaque filehandle which uniquely identifies the file and which can be used by an NFS client to access the file in the future.

Its arguments are:

vp
The vnode to make a filehandle for.
fhp
Return parameter for the filehandle.

VFS(9), VFS_FHTOVP(9), vnode(9)

This man page was written by Doug Rabson.

July 24, 1996 DragonFly-5.6.1