man.bsd.lv manual page server

Manual Page Search Parameters

VFS_FHTOVP(9) Kernel Developer's Manual VFS_FHTOVP(9)

VFS_FHTOVPturn an NFS filehandle into a vnode

#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>

int
VFS_FHTOVP(struct mount *mp, struct fid *fhp, struct vnode **vpp);

This is used by the NFS server to turn an NFS filehandle into a vnode.

Its arguments are:

mp
The filesystem.
fhp
The filehandle to convert.
vpp
Return parameter for the new locked vnode.

The contents of the filehandle are defined by the filesystem and are not examined by any other part of the system. It should contain enough information to uniquely identify a file within the filesystem as well as noticing when a file has been removed and the filesystem resources have been reused for a new file. For instance, UFS filesystem stores the inode number and inode generation counter in its filehandle.

A call to this function should generally be preceded by a call to VFS_CHECKEXP(9) to check if the file is accessible to the client.

The locked vnode for the file will be returned in *vpp.

VFS(9), VFS_CHECKEXP(9), VFS_VPTOFH(9), vnode(9)

This man page was written by Doug Rabson.

July 24, 1996 DragonFly-5.6.1