man.bsd.lv manual page server

Manual Page Search Parameters

VFS_UNMOUNT(9) Kernel Developer's Manual VFS_UNMOUNT(9)

VFS_UNMOUNTunmount a filesystem

#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>

int
VFS_UNMOUNT(struct mount *mp, int mntflags, struct proc *p);

Unmount a filesystem.

Its arguments are:

mp
The filesystem.
mntflags
Various flags.
p
Process which is unmounting the filesystem.

If the MNT_FORCE flag is specified then open files should be forcibly closed.

vflush(9), VFS(9), vnode(9)

This man page was written by Doug Rabson.

July 24, 1996 DragonFly-5.6.1