man.bsd.lv manual page server

Manual Page Search Parameters

VFLUSH(9) Kernel Developer's Manual VFLUSH(9)

vflushflush vnodes for a mount point

#include <sys/param.h>
#include <sys/vnode.h>

int
vflush(struct mount *mp, int rootrefs, int flags);

The () function removes any vnodes in the vnode table that belong to the given mount structure.

Its arguments are:

mp
The mount point whose vnodes should be removed.
rootrefs
The number of references expected on the root vnode. vrele(9) will be invoked on the root vnode rootrefs times.
flags
The flags indicating how vnodes should be handled.
If set, busy vnodes will be forcibly closed.
If set, vnodes with the VSYSTEM flag set will be skipped.
If set, only regular files currently opened for writing will be removed.

A value of 0 is returned if the flush is successful; otherwise, EBUSY will be returned.

vrele(9)

This manual page was written by Chad David <davidc@acns.ab.ca>.

November 21, 2001 DragonFly-5.6.1