man.bsd.lv manual page server

Manual Page Search Parameters

VFS_MOUNT(9) Kernel Developer's Manual VFS_MOUNT(9)

VFS_MOUNTmount a filesystem

#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>

int
VFS_MOUNT(struct mount *mp, char *path, caddr_t data, struct ucred *cred);

Mount a filesystem into the system's namespace.

Its arguments are:

mp
Structure representing the filesystem.
path
Pathname where the filesystem is being mounted.
data
Filesystem specific data. This should be read into the kernel using copyin(9).
cred
Pointer to a struct ucred for user credentials checking.

This is called both to mount new filesystems and to change the attributes of an existing filesystem. If the MNT_UPDATE flag is set in mp->mnt_flag then the filesystem should update its internal state from the value of mp->mnt_flag. This can be used, for instance, to convert a read-only filesystem to read-write. It is also used by mountd(8) to update the NFS export information for the filesystem.

If the MNT_UPDATE flag is not specified, then this is a newly mounted filesystem. The filesystem code should allocate and initialize any private data needed to represent the filesystem (it can use the mp->mnt_data field to store this information).

VFS(9), vnode(9)

This man page was written by Doug Rabson.

December 16, 2012 DragonFly-5.6.1