man.bsd.lv manual page server

Manual Page Search Parameters

WSKBD(4) Device Drivers Manual WSKBD(4)

wskbdgeneric keyboard support in wscons

wskbd* at pckbd? console ? mux 1 (standard PC keyboard)
wskbd* at ukbd? console ? mux 1 (USB keyboard)
wskbd* at lkkbd? console ? mux 1 (DEC LK200/400 serial keyboard)
wskbd0 at akbd? console ? mux 1 (Apple ADB keyboard)
wskbd0 at nextkbd? console ? mux 1 (NeXT keyboard)
wskbd* at vrkiu? console ? mux 1 (NEC VR4000 series HPC keyboard)
wskbd* at skbd? console ? mux 1 (keyboard of misc hpcmips handheld devices)
wskbd* at btkbd? console ? mux 1 (Bluetooth keyboard)

The wskbd driver handles common tasks for keyboards within the wscons(4) framework. It is attached to the hardware specific keyboard drivers and provides their connection to “wsdisplay” devices and a character device interface.

The common keyboard support consists of:

The wskbd driver provides a number of ioctl functions to control key maps and other parameters. These functions are accessible though the associated “wsdisplay” device as well. A complete list is in /usr/include/dev/wscons/wsconsio.h. The wsconsctl(8) utility allows to access key maps and other variables.

The locator in the configuration line refers to the device's use as input part of the operating system console. A device specification containing a positive value here will only match if the device is in use as system console. (The console device selection in early system startup is not influenced.) This way, the console device can be connected to a known wskbd device instance.

The following encodings are supported. Device drivers for legacy keyboard interfaces may only support a subset of these. However, generally, all encodings are supported by pckbd(4) and ukbd(4).

KB_USER User-defined
KB_US English/US keyboard mapping (default)
KB_UK English/UK keyboard mapping
KB_BE Belgian
KB_BR Brazilian with “dead accents”
KB_CF Canadian French
KB_CZ Czech (QWERTY)
KB_DK Danish with “dead accents”
KB_NL Dutch
KB_EE Estonian with “dead accents”
KB_FI Finnish
KB_FR French
KB_DE German with “dead accents”
KB_GR Greek
KB_HU Hungarian
KB_IS Icelandic with “dead accents”
KB_IT Italian
KB_JP Japanese
KB_LA Latin American Spanish
KB_NO Norwegian with “dead accents”
KB_PL Polish
KB_PT Portuguese
KB_RU Russian
KB_ES Spanish
KB_SV Swedish with “dead accents”
KB_SF Swiss French
KB_SG Swiss German
KB_TR Turkish (QWERTY) with “dead accents”
KB_UA Ukrainian
KB_US|KB_DECLK English/US mapping for DEC
LK400-style keyboards with PC keyboard
interface (e.g., LK461)
KB_US|KB_DVORAK English/US keyboard with
“Dvorak” layout
KB_US|KB_COLEMAK English/US keyboard with
“Colemak” layout

KB_NODEAD ( “.nodead”) can be applied to layouts with “dead accents” to switch them off.

The KB_US, KB_UK, KB_FR, KB_JP and KB_US|KB_DVORAK mappings can be modified to swap the left CTRL and the CAPS LOCK keys by the KB_SWAPCTRLCAPS variant bit or the “.swapctrlcaps” suffix.

The KB_METAESC ( “.metaesc”) option can be applied to any layout. If set, keys pressed together with the ALT modifier are prefixed by an ESC character. (Standard behaviour is to add 128 to the ASCII value.)

The following ioctl(2) calls are provided by the wskbd driver or by devices which use it. Their definitions are found in dev/wscons/wsconsio.h.

Get the keyboard type.
(struct wsmouse_repeat)
Get and set keyboard bell settings.
(struct wskbd_keyrepeat_data)
Get and set keyboard autorepeat settings.
(int)
Get and set keyboard LED settings.
(struct wskbd_map_data)
Get and set keyboard keymapping settings.
(kbd_t)
Get and set keyboard encoding settings.
(int)
Get and set keyboard keyclick settings.
(int)
Set the wscons_event protocol version. The default is 0 for binary compatibility. The latest version is always available as WSKBD_EVENT_VERSION, and is currently 1. All new code should use a call similar to the below to ensure the correct version is returned.
int ver = WSKBD_EVENT_VERSION;
if (ioctl(fd, WSKBDIO_SETVERSION, &ver) == -1)
    err(EXIT_FAILURE, "cannot set version");

btkbd(4), pckbd(4), ukbd(4), wscons(4), wsmux(4), wsconsctl(8), wskbd(9)

The list of builtin mappings doesn't follow any logic. It grew as people submitted what they needed.

July 13, 2020 NetBSD-9.2