man.bsd.lv manual page server

Manual Page Search Parameters

USERRET(9) Kernel Developer's Manual USERRET(9)

userretreturn path to user-mode execution

#include <sys/lwp.h>
#include <sys/sched.h>

void
userret(struct lwp *l);

The () function is executed after processing a trap (e.g., a system call or interrupt) before returning to user-mode execution. The implementation is machine dependent and is never invoked from machine-independent code. The function prototype for each architecture may be different to the prototype above, however the functionally provided by the userret() function on each architecture is essentially the same.

Specifically, the () function performs the following procedure:

cpu_need_resched(9), postsig(9), preempt(9), scheduler(9)

December 20, 2005 NetBSD-9.2