man.bsd.lv manual page server

Manual Page Search Parameters

SUSPENDSCHED(9) Kernel Developer's Manual SUSPENDSCHED(9)

suspendschedsuspend the scheduler

#include <sys/proc.h>
#include <sys/sched.h>

void
suspendsched(void);

The () function suspends the operation of the scheduler by stopping all non-system processes which are on the run queue or the sleep queue.

The () function must not be called with the scheduler lock held.

September 21, 2002 NetBSD-9.2