man.bsd.lv manual page server

Manual Page Search Parameters

SETJMP(9) Kernel Developer's Manual SETJMP(9)

setjmp, longjmpnon-local jumps

#include <machine/types.h>
#include <sys/systm.h>

int
setjmp(label_t *label);

void
longjmp(label_t *label);

The () function saves its calling environment in label. It returns zero on success. The () function restores the environment saved by the most recent invocation of setjmp(). It returns so that kernel execution continues as if the corresponding invocation of the setjmp() had just returned.

() and () are a machine-independent interface for machine-dependent implementations.

These functions are primarily used by ddb(4).

ddb(4)

May 23, 2002 NetBSD-9.2