man.bsd.lv manual page server

Manual Page Search Parameters

MEMMOVE(9) Kernel Developer's Manual MEMMOVE(9)

memmovecopy byte string

#include <sys/systm.h>

void *
memmove(void *dst, const void *src, size_t len);

The () function copies len bytes from string src to string dst. The two strings may overlap; the copy is always done in a non-destructive manner.

The memmove() function returns the original value of dst.

memcpy(9)

The memmove() function conforms to ANSI X3.159-1989 (“ANSI C89”).

July 7, 2001 NetBSD-9.2