man.bsd.lv manual page server

Manual Page Search Parameters

M_TAG(9) Kernel Developer's Manual M_TAG(9)

m_tag, m_tag_get, m_tag_free, m_tag_prepend, m_tag_unlink, m_tag_delete, m_tag_delete_chain, m_tag_find, m_tag_copy, m_tag_copy_chainmbuf tagging interfaces

#include <sys/mbuf.h>

struct m_tag *
m_tag_get(int type, int len, int wait);

void
m_tag_free(struct m_tag *t);

void
m_tag_prepend(struct mbuf *m, struct m_tag *t);

void
m_tag_unlink(struct mbuf *m, struct m_tag *t);

void
m_tag_delete(struct mbuf *m, struct m_tag *t);

void
m_tag_delete_chain(struct mbuf *m);

struct m_tag *
m_tag_find(struct mbuf *m, int type);

struct m_tag *
m_tag_copy(struct m_tag *m);

int
m_tag_copy_chain(struct mbuf *to, struct mbuf *from);

The m_tag interface is used to “tag” mbufs.

(type, len, wait)
Allocate an mbuf tag. type is one of the PACKET_TAG_ macros. len is the size of the data associated with the tag, in bytes. wait is either M_WAITOK or M_NOWAIT.
(t)
Free the mbuf tag t.
(m, t)
Prepend the mbuf tag t to the mbuf m. t will become the first tag of the mbuf m. When m is freed, t will also be freed.
Unlink the mbuf tag t from the mbuf m.
(m, t)
The same as m_tag_unlink() followed by m_tag_free().
(m)
Unlink and free mbuf tags from the mbuf m.
(m, type)
Find an mbuf tag with type type in the tag chain associated with the mbuf m. If an mbuf tag is found, return a pointer to it. Otherwise return NULL.
(t)
Copy an mbuf tag t. Return a new mbuf tag on success. Otherwise return NULL.
(to, from)
Copy all mbuf tags associated with the mbuf from to the mbuf to. If to already has any mbuf tags, they will be unlinked and freed beforehand. Return 1 on success. Otherwise return 0.

The mbuf tagging interfaces are implemented within the file sys/kern/uipc_mbuf.c.

The PACKET_TAG_ macros are defined in the file sys/sys/mbuf.h.

intro(9), malloc(9), mbuf(9)

The semantics of the term "persistent tag" are vague.

November 15, 2018 NetBSD-9.2