man.bsd.lv manual page server

Manual Page Search Parameters

INTERSIL7170(4) Device Drivers Manual INTERSIL7170(4)

intersil7170Intersil ICM7170 time-of-day clock driver

#include <dev/ic/intersil7170reg.h>
#include <dev/ic/intersil7170var.h>

define intersil7170
file dev/ic/intersil7170.c intersil7170

The intersil7170 driver provides access to the Intersil ICM7170 time-of-day clock chip. Access methods to retrieve and set date and time are provided through the interface defined in todr(9).

To tie an instance of this device to the system, use the () function and the intersil7170_softc structure defined as follows:

void (struct intersil7170_softc *)

struct intersil7170_softc {
	struct device	sc_dev;
	bus_space_tag_t	sc_bst;
	bus_space_handle_t sc_bsh;
	struct todr_chip_handle sc_handle;
	u_int		sc_year0;
	u_int		sc_flag;
};
bus_tag
 
bus_handle
Specify bus space access to the chip's non-volatile memory (including the clock registers).
sc_handle
TODR handle passed to the () function to register todr(9) interface.
sc_year0
The actual year represented by the clock's ‘year’ counter. This is generally dependent on the system configuration in which the clock device is mounted. For instance, on Sun Microsystems machines the convention is to have clock's two-digit year represent the year 1968.
sc_flag
This flag is used to specify machine-dependent features.

Note that if the resulting date retrieved with the todr_gettime() method is earlier that January 1, 1970, the driver will assume that the chip's year counter actually represents a year in the 21st century. This behaviour can be overridden by setting the INTERSIL7170_NO_CENT_ADJUST flag in sc_flag.

intro(4), todr(9)

The intersil7170 driver first appeared in NetBSD 1.5.

The intersil7170 driver was written by Paul Kranenburg ⟨pk@NetBSD.org⟩.

October 1, 2006 NetBSD-9.2