man.bsd.lv manual page server

Manual Page Search Parameters

IEEE80211_IOCTL(9) Kernel Developer's Manual IEEE80211_IOCTL(9)

ieee80211_cfgget, ieee80211_cfgset, ieee80211_ioctl802.11 interface ioctl commands

#include <net80211/ieee80211_var.h>
#include <net80211/ieee80211_proto.h>
#include <net80211/ieee80211_ioctl.h>

int
ieee80211_cfgget(struct ieee80211com *ic, u_long cmd, void *data);

int
ieee80211_cfgset(struct ieee80211com *ic, u_long cmd, void *data);

int
ieee80211_ioctl(struct ieee80211com *ic, u_long cmd, void *data);

These functions are typically invoked by drivers in response to requests for information or to change settings from the userland.

The () and () functions implement a legacy interface for getting and setting 802.11 interface attributes respectively. The interface is compatible with the RIDs implemented by the wi(4) driver and used by the wiconfig(8) utility.

The () function implements ioctls such as key management for wireless devices. Ioctls related to the Ethernet layer also pass through here, but are handed off to () when no match for cmd is found.

wi(4), ifconfig(8), wiconfig(8), ieee80211(9)

The ieee80211 series of functions first appeared in NetBSD 1.5, and were later ported to FreeBSD 4.6.

This man page was written by Bruce M. Simpson <bms@FreeBSD.org> and Darron Broad <darron@kewl.org>.

September 12, 2006 NetBSD-9.2