man.bsd.lv manual page server

Manual Page Search Parameters

IASL(8) System Manager's Manual IASL(8)

iaslIntel ASL compiler and disassembler (iASL)

iasl [options] ⟨input file

The iasl is a fully-featured compiler for the ACPI Source Language (ASL). It translates ASL to ACPI Machine Language (AML), but iasl can also act as a disassembler, translating AML to ASL.

file
Specify command file.
dir
Specify additional include directory.

prefix
Specify a path or filename prefix for all output files.
Disable all errors and warnings in the summary.
Use less verbose errors and warnings.
Enable optimization comments.
Disable remarks.
Disable signon.
1 | 2 | 3
Set warning reporting level.

a | c
Create AML in assembler (*.asm) or C (*.c) source file.
a | c
Create assembler (*.inc) or C (*.h) include file.
a | c
Create AML in assembler or C hex table (*.hex).

Disable all optimizations (compatibility mode).
Disable constant folding.
Disable integer optimization to operation codes.
Disable named reference string optimization.
revision
Override table header revision (1-255).

Create mixed, ASL and AML, listing file (*.lst).
Create namespace file (*.nsp).
Create combined source file (*.src).

file
Disassemble binary ACPI table to a file (*.dsl).
file
Disassemble AML and immediately compile it.
f1, f2
Include ACPI table(s) for external symbol resolution.
Emit ACPI 2.0 compatible ASL code.
Get ACPI tables and write to files (*.dat).

Display additional help and compiler debug options.
Display operators allowed in constant expressions.
Display ACPI reserved method names.

acpi(4), acpidump(8), amldb(8)

Intel Corporation, iASL Compiler/Disassembler User Reference, Revision 2.00, http://www.acpica.org/download/aslcompiler.pdf, September 18, 2009.

The iasl compiler/disassembler is part of the Intel ACPI Component Architecture (ACPICA). It first appeared in NetBSD 6.0.

Among Intel engineers, Robert Moore <robert.moore@intel.com> was the chief architect behind iasl. This manual page was written for NetBSD by Jukka Ruohonen <jruohonen@iki.fi>.

April 10, 2010 NetBSD-9.2