man.bsd.lv manual page server

Manual Page Search Parameters

CPU_DUMPCONF(9) Kernel Developer's Manual CPU_DUMPCONF(9)

cpu_dumpconf, cpu_dump, cpu_dumpsize, dumpsysmachine-dependent kernel core dumps

#include <sys/types.h>
#include <sys/systm.h>

void
cpu_dumpconf(void);

int
cpu_dump(int (*dump)(dev_t, daddr_t, void *, size_t), daddr_t *blknop);

int
cpu_dumpsize(void);

void
dumpsys(void);

() is the machine-dependent interface invoked during system bootstrap to determine the dump device and initialize machine-dependent kernel core dump state. Internally, cpu_dumpconf() will invoke cpu_dumpsize() to calculate the size of machine-dependent kernel core dump headers.

() is invoked by () to dump kernel physical memory onto the dump device. dumpsys() invokes cpu_dump() to write the machine-dependent header to the dump device at block number *blknop using the dump device's PIO dump routine specified by the dump argument.

(), (), and dumpsys() are parts of the machine-dependent interface, however they are not exported to machine-independent code.

cpu_reboot(9)

May 24, 2002 NetBSD-9.2