man.bsd.lv manual page server

Manual Page Search Parameters

STORE(9) Kernel Developer's Manual STORE(9)

store, subyte, suibyte, susword, suswintr, suword, suiwordstore data to user-space

#include <sys/types.h>
#include <sys/systm.h>

int
subyte(void *base, int c);

int
susword(void *base, short c);

int
suswintr(void *base, short c);

int
suword(void *base, long c);

The store functions are designed to copy small amounts of data to the user-space of the currently running process.

The store routines provide the following functionality:

()
Stores a byte of data to the user-space address base.
()
Stores a short word of data to the user-space address base.
()
Stores a short word of data to the user-space address base. This function is safe to call during an interrupt context.
()
Stores a word of data to the user-space address base.

The store functions return 0 on success or -1 on failure.

copy(9), fetch(9)

January 7, 1996 NetBSD-8.0