man.bsd.lv manual page server

Manual Page Search Parameters

VM_MAP_CREATE(9) Kernel Developer's Manual VM_MAP_CREATE(9)

vm_map_createcreate a new vm_map structure

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/vm_map.h>

vm_map_t
vm_map_create(pmap_t pmap, vm_offset_t min, vm_offset_t max);

The () function creates and returns a new, empty map structure, associated with the physical map pmap, and with the upper and lower address bounds specified by max and min respectively.

The kernel's zone allocator is used to allocate the map.

The vm_map_create() function returns a pointer to the newly allocated map if successful. Otherwise, it returns NULL.

pmap(9), vm_map(9), vm_map_init(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.

July 19, 2003 FreeBSD-12.0