man.bsd.lv manual page server

Manual Page Search Parameters

VFS_ROOTMOUNTALLOC(9) Kernel Developer's Manual VFS_ROOTMOUNTALLOC(9)

vfs_rootmountallocallocate a root mount structure

#include <sys/param.h>
#include <sys/mount.h>

int
vfs_rootmountalloc(char *fstypename, char *devname, struct mount **mpp);

() allocates a mount structure initialized from the vfsconf type that matches fstypename.

If successful, 0 is returned and mpp points to the newly allocated mount structure. ENODEV is returned if fstypename is NULL or invalid.

vfsconf(9)

This manual page was written by Chad David <davidc@acns.ab.ca>.

November 21, 2001 FreeBSD-12.0