man.bsd.lv manual page server

Manual Page Search Parameters

UIDINFO(9) Kernel Developer's Manual UIDINFO(9)

uidinfo, uihashinit, uifind, uihold, uifreefunctions for managing UID information

#include <sys/param.h>
#include <sys/proc.h>
#include <sys/resourcevar.h>

void
uihashinit(void);

struct uidinfo *
uifind(uid_t uid);

void
uihold(struct uidinfo *uip);

void
uifree(struct uidinfo *uip);

The uidinfo family of functions is used to manage uidinfo structures. Each uidinfo structure maintains per uid resource consumption counts, including the process count and socket buffer space usage.

The () function initializes the uidinfo hash table and its mutex. This function should only be called during system initialization.

The () function looks up and returns the uidinfo structure for uid. If no uidinfo structure exists for uid, a new structure will be allocated and initialized. The uidinfo hash mutex is acquired and released.

The () function increases the reference count on uip. uip's lock is acquired and released.

The () function decreases the reference count on uip, and if the count reaches 0 uip is freed. uip's lock is acquired and release and the uidinfo hash mutex may be acquired and released.

uifind() returns a pointer to an initialized uidinfo structure, and should not fail.

This manual page was written by Chad David <davidc@acns.ab.ca>.

July 10, 2001 FreeBSD-12.0