man.bsd.lv manual page server

Manual Page Search Parameters

STYLE.MAKEFILE(5) File Formats Manual STYLE.MAKEFILE(5)

style.MakefileFreeBSD Makefile file style guide

This file specifies the preferred style for makefiles in the FreeBSD source tree.

The desire to express a logical grouping often means not obeying some of the above.

The simplest program Makefile is:

# $FreeBSD$

PROG=	foo

.include <bsd.prog.mk>

The simplest library Makefile is:

# $FreeBSD$

LIB=	foo
SHLIB_MAJOR= 1
MAN=	libfoo.3
SRCS=	foo.c

.include <bsd.lib.mk>

make(1), make.conf(5), style(9)

This manual page is inspired from the same source as style(9) manual page in FreeBSD.

There are few hard and fast style rules here. The style of many things is too dependent on the context of the whole makefile, or the lines surrounding it.

October 21, 2015 FreeBSD-12.0