man.bsd.lv manual page server

Manual Page Search Parameters

PRISON_CHECK(9) Kernel Developer's Manual PRISON_CHECK(9)

prison_checkdetermine if two credentials belong to the same jail

#include <sys/jail.h>

int
prison_check(struct ucred *cred1, struct ucred *cred2);

This function can be used to determine if the two credentials cred1 and cred2 belong to the same jail.

The prison_check() function returns ESRCH if cred1 has been jailed, and cred1 and cred2 do not belong to the same jail. In all other cases, prison_check() returns zero.

jail(2)

December 11, 2003 FreeBSD-12.0