man.bsd.lv manual page server

Manual Page Search Parameters

PMAP_PAGE_EXISTS_QUICK(9) Kernel Developer's Manual PMAP_PAGE_EXISTS_QUICK(9)

pmap_page_exists_quickdetermine if a page exists in a physical map

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/pmap.h>

boolean_t
pmap_page_exists_quick(pmap_t pmap, vm_page_t m);

The () function is used to quickly determine if the page m exists in the physical map pmap. It is typically called from the VM paging code.

The PV count used above may be changed upwards or downwards in future; it is only necessary that TRUE be returned for a small subset of pmaps for proper page aging.

The pmap_page_exists_quick() returns TRUE only if the PV entry for the physical map pmap is one of the first 16 PVs linked from the page m.

pmap(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.

July 21, 2003 FreeBSD-12.0