man.bsd.lv manual page server

Manual Page Search Parameters

PMAP_IS_PREFAULTABLE(9) Kernel Developer's Manual PMAP_IS_PREFAULTABLE(9)

pmap_is_prefaultabledetermine if a page may be prefaulted

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/pmap.h>

boolean_t
pmap_is_prefaultable(pmap_t pmap, vm_offset_t va);

The () function provides a means of determining if the page residing at virtual address va in the physical map pmap may be pre-faulted into main memory.

This is a helper function which is called by vm_fault_prefault(9).

pmap(9), vm_fault_prefault(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.

July 21, 2003 FreeBSD-12.0