man.bsd.lv manual page server

Manual Page Search Parameters

PMAP_COPY(9) Kernel Developer's Manual PMAP_COPY(9)

pmap_copy, pmap_copy_pagecopy physical memory pages

#include <sys/param.h>
#include <vm/vm.h>
#include <vm/pmap.h>

void
pmap_copy(pmap_t dst_pmap, pmap_t src_pmap, vm_offset_t dst_addr, vm_size_t len, vm_offset_t src_addr);

void
pmap_copy_page(vm_page_t src, vm_page_t dst);

The () function copies the range specified by src_addr and len from the source physical map src_pmap to the destination physical map dst_pmap at the address dst_addr.

The () function copies the physical page src to the physical page dst, by mapping the page into kernel virtual address space (KVA), and using () to copy the page.

The pmap_copy() routine is only advisory and need not do anything. Actually implementing it may seriously reduce system performance.

The pmap_copy_page() routine only operates upon a single page.

bcopy(3), pmap(9)

This manual page was written by Bruce M Simpson <bms@spc.org>.

July 21, 2003 FreeBSD-12.0