man.bsd.lv manual page server

Manual Page Search Parameters

NG_UI(4) Device Drivers Manual NG_UI(4)

ng_UIUI netgraph node type

#include <netgraph/ng_UI.h>

The UI node type has two hooks, upstream and downstream. Packets received on downstream must have 0x03 (indicating unnumbered information) as their first byte; if not the packet is dropped. This byte is then stripped and the remainder of the packet sent out on upstream.

Conversely, packets received on upstream will have a 0x03 byte prepended to them before being forwarded out on the downstream hook.

This node type supports the following hooks:

downstream
Downstream connection. Packets on this side of the node have a 0x03 as their first byte.
upstream
Upstream connection. Packets on this side of the node have the initial 0x03 byte stripped off.

This node type supports only the generic control messages.

This node shuts down upon receipt of a NGM_SHUTDOWN control message, or when both hooks have been disconnected.

netgraph(4), ngctl(8)

The ng_UI node type was implemented in FreeBSD 4.0.

Julian Elischer <julian@FreeBSD.org>

January 19, 1999 FreeBSD-12.0