man.bsd.lv manual page server

Manual Page Search Parameters

HCSECD.CONF(5) File Formats Manual HCSECD.CONF(5)

hcsecd.confhcsecd(8) configuration file

The hcsecd.conf file is the configuration file for the hcsecd(8) Bluetooth link keys/PIN codes management daemon.

The hcsecd.conf file is a free-form ASCII text file. It is parsed by the recursive-descent parser built into hcsecd(8). The file may contain extra tabs and newlines for formatting purposes. Keywords in the file are case-sensitive. Comments may be placed anywhere within the file (except within quotes). Comments begin with the ‘#’ character and end at the end of the line.

The hcsecd.conf file consists of a list of device entries. Each device entry defines a link key or PIN code for a remote Bluetooth device. Each remote Bluetooth device is identified by its unique BD_ADDR.

The device entry

device { option argument; [option argument;] }

The following section describes all supported options and arguments.

BD_ADDR
Specify remote device BD_ADDR for the entry.
device_name
Specify user friendly name for the entry. Name is a string in straight double quotes.
link_key
Specify link key for the entry. Link key is hexadecimal string up to 32 characters in length starting with ‘0x’.
Specify no link key for the entry.
PIN_code
Specify PIN code for the entry. PIN code is a string up to 16 characters in length in straight double quotes.
Specify no PIN code for the entry.

A sample hcsecd.conf file:

# Default entry is applied if no better match found
# It MUST have 00:00:00:00:00:00 as bdaddr
device {
        bdaddr  00:00:00:00:00:00;
        name    "Default entry";
        key     nokey;
        pin     nopin;
}

# Ericsson T68 phone
device {
        bdaddr  00:80:37:5e:4d:d4;
        name    "Ericsson T68 phone";
        key     nokey;
        pin     "0000"; # PIN code
}

# Dummy device
device {
        bdaddr  00:11:22:33:44:55;
        name    "Dummy";
        key     0x00112233445566778899aabbccddeeff; # 16 bytes key
        pin     nopin;
}

hcsecd(8)

Maksim Yevmenkin <m_evmenkin@yahoo.com>

May 26, 2003 FreeBSD-12.0