man.bsd.lv manual page server

Manual Page Search Parameters

DEVICE_GET_SOFTC(9) Kernel Developer's Manual DEVICE_GET_SOFTC(9)

device_get_softcaccess driver private instance variables

#include <sys/param.h>
#include <sys/bus.h>

void *
device_get_softc(device_t dev);

Return the driver-specific software context of dev. The softc is automatically allocated and zeroed when the device is attached. The softc is also initialized and present when a device is probed, but is subject to caveats as described in DEVICE_PROBE(9). The size of the allocation is determined by the device's driver_t information used to define the driver. The softc typically encapsulates the state of this instance of the device.

Driver writers are discouraged from using their own softc management mechanisms. Driver writers should not copy such mechanisms found in drivers in the tree that predate this function.

The pointer to the driver-specific instance variable is returned.

device(9), DEVICE_PROBE(9), device_set_softc(9), driver(9)

This manual page was written by Doug Rabson.

January 21, 2015 FreeBSD-12.0