man.bsd.lv manual page server

Manual Page Search Parameters

DEVICE_GET_IVARS(9) Kernel Developer's Manual DEVICE_GET_IVARS(9)

device_get_ivars, device_set_ivarsaccess bus private variables

#include <sys/param.h>
#include <sys/bus.h>

void *
device_get_ivars(device_t dev);

void
device_set_ivars(device_t dev, void *ivar);

The () function returns the bus-specific instance variables of a device.

The () function sets the bus-specific instance variables of a device.

Typically, only bus drivers will use these functions. The kernel assumes that the bus driver will manage this memory, and no automatic memory allocation or deallocation happens. Client drivers should access ivars through the BUS_READ_IVAR(9) interface instead.

device(9)

This manual page was written by Doug Rabson.

June 16, 1998 FreeBSD-12.0