man.bsd.lv manual page server

Manual Page Search Parameters

DEVICE_SET_DESC(9) Kernel Developer's Manual DEVICE_SET_DESC(9)

device_set_desc, device_set_desc_copy, device_get_descaccess the description of a device

#include <sys/param.h>
#include <sys/bus.h>

void
device_set_desc(device_t dev, const char *desc);

void
device_set_desc_copy(device_t dev, const char *desc);

const char *
device_get_desc(device_t dev);

Manipulate the verbose description of a device. This description (if present) is printed as part of the message when it is attached during autoconfiguration. The variation () is used to set the description if the string passed is a temporary buffer which will be overwritten. In this case, the system will copy the string, otherwise the pointer passed will be used directly.

device(9)

This manual page was written by Doug Rabson.

June 16, 1998 FreeBSD-12.0