man.bsd.lv manual page server

Manual Page Search Parameters

DEVCLASS_GET_MAXUNIT(9) Kernel Developer's Manual DEVCLASS_GET_MAXUNIT(9)

devclass_get_maxunitfind the maximum unit number in the class

#include <sys/param.h>
#include <sys/bus.h>

int
devclass_get_maxunit(devclass_t dc);

Returns the next unit number to be allocated to device instances in the devclass. This is one greater than the highest currently allocated unit.

The devclass_get_maxunit() function returns -1 if dc is NULL, otherwise it returns the next unit number in dc's devclass.

None.

devclass(9), device(9)

This manual page was written by Doug Rabson.

The name is confusing since it is one greater than the maximum unit.

September 10, 2010 FreeBSD-12.0