man.bsd.lv manual page server

Manual Page Search Parameters

VOP_REVOKE(9) Kernel Developer's Manual VOP_REVOKE(9)

VOP_REVOKErevoke access to a device and its aliases

#include <sys/param.h>
#include <sys/vnode.h>

int
VOP_REVOKE(struct vnode *vp, int flags);

() will administratively revoke access to the device specified by vp, as well as any aliases created via make_dev_alias(9). Further file operations on any of these devices by processes which have them open will nominally fail. The flags must be set to REVOKEALL to signify that all access will be revoked; any other value is invalid.

The vp must be unlocked on entry, and will remain unlocked upon return.

make_dev_alias(9), vnode(9)

This manual page was written by Brian Fundakowski Feldman.

February 5, 2002 FreeBSD-12.0