man.bsd.lv manual page server

Manual Page Search Parameters

VOP_REALLOCBLKS(9) Kernel Developer's Manual VOP_REALLOCBLKS(9)

VOP_REALLOCBLKSrearrange blocks in a file to be contiguous

#include <sys/param.h>
#include <sys/vnode.h>

int
VOP_REALLOCBLKS(struct vnode *vp, struct cluster_save *buflist);

The arguments are:
vp
The file to manipulate.
buflist
A list of buffers to rearrange.

This seems to be part of a work in progress.

Zero is returned on success, otherwise an error is returned.

buf(9), vnode(9)

This manual page was written by Doug Rabson.

July 24, 1996 FreeBSD-12.0