man.bsd.lv manual page server

Manual Page Search Parameters

VOP_READLINK(9) Kernel Developer's Manual VOP_READLINK(9)

VOP_READLINKread the target of a symbolic link

#include <sys/param.h>
#include <sys/vnode.h>
#include <sys/uio.h>

int
VOP_READLINK(struct vnode *vp, struct uio *uio, struct ucred *cred);

This reads the target pathname of a symbolic link
vp
The vnode of the symlink.
uio
The location of the data to be read or written.
cred
The credentials of the caller.

The vnode should be locked on entry and will still be locked on exit.

Zero is returned on success, otherwise an error code is returned.

[]
A read error occurred while reading the contents of the symlink.

uiomove(9), vnode(9)

This manual page was written by Doug Rabson.

July 24, 1996 FreeBSD-12.0