man.bsd.lv manual page server

Manual Page Search Parameters

VOP_PATHCONF(9) Kernel Developer's Manual VOP_PATHCONF(9)

VOP_PATHCONFreturn POSIX pathconf information

#include <sys/param.h>
#include <sys/vnode.h>
#include <sys/unistd.h>

int
VOP_PATHCONF(struct vnode *vp, int name, int *retval);

The arguments are:
vp
The vnode to get information about.
name
The type of information to return.
retval
The place to return the information.

The value of name specifies what should be returned:

The maximum number of links to a file.
The maximum number of bytes in a file name.
The maximum number of bytes in a pathname.
The maximum number of bytes which will be written atomically to a pipe.
Return 1 if appropriate privileges are required for the chown(2) system call, otherwise 0.
Return 1 if file names longer than KERN_NAME_MAX are truncated.

If name is recognized, *retval is set to the specified value and zero is returned, otherwise EINVAL is returned.

pathconf(2), vnode(9)

This manual page was written by Doug Rabson.

July 24, 1996 FreeBSD-12.0